hamadata's diary

https://motion-gallery.net のエンジニアのブログ

Rails3とRails2の共存

gemを使って特定のバージョンのrailsをインストールができる。
Rails 2.3.5で開発していたサーバのrailsに、2.3.5と3.0.0の両方をインストールしたら、Passengerが、gem railsが無いとエラーを吐いて立ち上がらない。

sudo gem uninstall actionpack --version ">3.0"

と3系のgemを全部アンインストールしてみたら、とりあえず元の挙動に戻った。ちなみに、Passenger自体は最新のものにアップデートしても問題ない。