hamadata's diary

https://motion-gallery.net のエンジニアのブログ

Re:dashのprovisioning scriptで失敗した時の対応

Re:dashでデータ解析をする環境を立ち上げべく、色々触った時のメモ。

環境はUbuntu16.04 on vagrant

Re:dashはUbuntu16.04でテストされたプロビジョニングスクリプトを用意しているので、これをvagrant sshした先の bootstrap.sh で実行すれば良い。

Setting up a Redash instance · Redash Help Center

…はずが、うまくいかない。

どうやらpipのバージョンが古いのが原因らしいの。pipをアップグレードすれば問題が解決した。

sudo apt-get remove python-setuptools
sudo -H pip install -U pip setuptools

[参考文献]

deb - how to upgrade python setuptools > 12.2 on ubuntu 15.04 - Ask Ubuntu